CF.lumen version for Android 4.1.2?

I have an old Samsung Nexus S (model GT-I9020A) on Android 4.1.2 which I would like to resume using. I've rooted it (from a Ubuntu box) with android-tools-fastboot and -adb, using ClockworkMod's recovery and ClockworkMod's superuser.zip.

Is it possible to get CF.lumen working on this device? I notice the main links say it needs Android 5.0+. But I also tried direct .apk downloads for CF.lumen 3.16 and 3.00 as shown here

However if I try those .apk from the phone itself (downloads section), it gives an error pop-up that says "Parse error - There was a problem while parsing the package - OK". If I try them over the USB cable from my (Ubuntu) computer, it fails with "INSTALL_FAILED_OLDER_SDK":

Code:
$ adb install CF.lumen-v3.16.apk 2008 KB/s (712979 bytes in 0.346s) pkg: /data/local/tmp/CF.lumen-v3.16.apk Failure [INSTALL_FAILED_OLDER_SDK]

Is there a version of CF.lumen that could or should work on this phone? or am I doing something wrong? Or is this Android version (4.1.2) from the era (that I've seen described in some of Chainfire's posts) where it was described as not able to work with the OS?

Thanks.

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by sterling79
11 minutes ago
Last post by dibbert.freda
1 hour ago
Last post by oswald59
1 hour ago
Last post by boehm.edgardo
4 hours ago
Last post by bahringer.desmond
2 hours ago
Last post by raoul67
4 hours ago
Last post by leon66
1 hour ago
Last post by cornell27
3 hours ago
Last post by rraynor
3 hours ago
Last post by otilia.parker
4 hours ago